HomeCisco networkingCisco routerOSPF Authentication on Cisco Routers

OSPF Authentication on Cisco Routers

This tech-recipe describes configuring OSPF authentication to prevent unauthorized routing updates.


In this example, Router A and Router B are connected with a WAN link. The WAN is addressed as 192.168.0.0/30. Router A has 10.1.1.0/24, and Router B has 10.2.2.0/24 on their respective FastEthernet interfaces.

Configure OSPF for basic routing:

Router A:router ospf 100
network 10.1.1.0 0.0.0.255 area 10.1.1.0
network 192.168.0.0 0.0.0.3 area 0.0.0.0

Router B:router ospf 100
network 10.2.2.0 0.0.0.255 area 10.2.2.0
network 192.168.0.0 0.0.0.3 area 0.0.0.0

Now, the routing table in both routers should show OSPF routes.

Configure OSPF for authentication:

Router A:interface serial 0/0
ip ospf message-digest-key 10 md5 PASSWORD
router ospf 100
area 0 authentication message-digest

Router B:interface serial 0/0
ip ospf message-digest-key 10 md5 PASSWORD
router ospf 100
area 0 authentication message-digest

Now, the two routers should be authenticating updates.

RELATED ARTICLES

2 COMMENTS

LEAVE A REPLY

Please enter your comment!
Please enter your name here

- Advertisment -

Most Popular

Recent Comments

Cleveland Furia on How to Clear Google Activity
Sid Wohlfarth on How to Clear Google Activity
Riley Magsayo on How to Clear Google Activity
สมัครรับเครดิตฟรี ทันที on How to improve Remote Desktop Protocol Performance
Neal Wangstad on How to Clear Google Activity
Slavcho Andov on How to install Ubuntu
Slavcho Andov on How to fix bad sectors
Sheraz Ali on How to Backup Android