Configure Frame Relay on a Cisco Router

Posted February 10, 2004 by Al Banks in Cisco router

Frame relay is an attractive choice for wide-area network (WAN) connections. It offers simple configuration and allows one telco circuit to connect many locations. The following tutorial decribes configuring a frame relay.


First, note the following terminology:

    DLCI (Data Link Connection Identifier) – a number which directs traffic to different destinations

    CIR (Committed Information Rate) – Packets transmitted in excess of this rate will be marked as DE (Discard Eligible).

    BECN (Backwards Explicit Congestion Notification) – notifies devices of congestion in the network

    FECN (Forward Explicti Congestion Notification) – notifies devices of congestion in the network

    DE (Discard Eligible) – These frames may be dropped when congestion occurs.

NOTE: An unconfigured router is assumed with serial 0/0 and FastEthernet 0/0 interfaces available. This end of the frame relay connection will use DLCI 100. The 192.168.0.4/30 network will be used on the WAN link, 10.1.1.0/24 on the Ethernet, and 10.2.2.0/24 on the remote side.

Connect to the router’s console port, and enter the appropriate passwords. Then enter the following:

config t
This is short for configure terminal and allows entry of configuration commands.

interface FastEthernet0/0
This enters into interface configuration mode. The prompt should change to “router#(config-if).”

ip address 10.1.1.1 255.255.255.0
This address configures the FastEthernet port to use address 10.1.1.1. Machines on this subnet would use this address as the gateway to reach 10.2.2.0.

no shutdown
This enables the port. By default, ports are administratively down.

interface serial 0/0
This changes to interface configuration mode for the serial interface.

no shutdown
This enables the port. By default, ports are administratively down.

encapsulation frame-relay
This tells the router to transmit frame relay on this interface instead of serial (HDLC).

Now, there is a choice. The most common method is subinterfaces:

interface serial 0/0.100 point-to-point
This creates the subinterface. Note the 100 can be any number, but using the DLCI number makes troubleshooting easier.

ip address 192.168.0.5 255.255.255.252
This assigns the IP address to the subinterface.

frame-relay interface-dlci 100
This instructs the router to use DLCI 100 for traffic going out this interface and route inbound traffic from DLCI 100 through this interface. The process is complete.

Now, below is the other method known as frame mapping:

frame-relay map ip 192.168.0.6 100 broadcast
This associates the destination IP address with a DLCI.

Although the configuration is longer, subinterfaces are easier to troubleshoot. If a DLCI fails, the subinterface will appear down in the show ip interfaces brief output. Other useful commands include show frame-relay pvc and show frame lmi

The Conversation

Follow the reactions below and share your own thoughts.

  • Ron Beacom

    interface Serial0/0
    description Link to Router1
    no ip address
    encapsulation frame-relay
    no ip mroute-cache
    fair-queue
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 200 interface Serial0/1 201
    frame-relay route 300 interface Serial0/2 301
    frame-relay route 400 interface Serial0/3 401
    no shut
    !
    interface Serial0/1
    description link to router2
    no ip address
    encapsulation frame-relay
    no ip mroute-cache
    fair-queue
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 201 interface Serial0/0 200
    frame-relay route 203 interface Serial0/2 302
    frame-relay route 204 interface Serial0/3 402
    no shut
    !
    interface Serial0/2
    description Link to Router3
    no ip address
    encapsulation frame-relay
    no ip mroute-cache
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 301 interface Serial0/0 300
    frame-relay route 302 interface Serial0/1 203
    frame-relay route 304 interface Serial0/3 403
    no shut
    !
    interface Serial0/3
    description Link to Router4
    no ip address
    encapsulation frame-relay
    no ip mroute-cache
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 401 interface Serial0/0 400
    frame-relay route 402 interface Serial0/1 204
    frame-relay route 403 interface Serial0/2 304
    no shut