Layer 3 Switches

Posted February 25, 2004 by indianboy in Cisco switch

The following tech-recipe contains an overview of how Layer 3 switches work. Catalyst switches are normally used as Layer 3 switches. Thus, the switch can have an SUP engine, a redundant SUP engine, an RSM module and Layer 2 (Ethernet or Fast Ethernet) ports.

Functions of Different Modules

RSM (Route Switch Module): performs routing; mostly Inter-VLAN routing
SUP (Supervisor Engine): the switch part of the Layer 3 switch; mostly VLAN creation, etc.; redundant engines are commonly used
Layer-2 Ports : Ethernet or Fast Ethernet ports through which machines can be connected

Overview of Operation (Examples on Catalyst 5500 series)

1. VLANs are configured on the SUP engine:
Console> (enable) set vlan 10 name example-1
Console> (enable) set vlan 20 name example-2

2. The configuration can be viewed using the following command:
Console> (enable) sh vlan

3. Log in to the RSM module using this command:
Console> (enable) session 15 or (module number of RSM module)

4. Go to the enable mode and then the configure mode. The final result is as follows:
RSM(config)#

5. Create the virtual interfaces on RSM for the VLANs created in SUP engine.
RSM(config)#interface vlan 10
RSM(config)#interface vlan 20

6. Enter into the specific interfaces, and add IP addresses:
RSM(config)#interface vlan 10
RSM(config-if)#ip address 10.10.10.1 255.255.255.0
RSM(config-if)#description ***Example-1_Interface ***
RSM(config-if)#no shut
RSM(config)#interface vlan 20
RSM(config-if)#ip address 10.10.20.1 255.255.255.0
RSM(config-if)#description ***Example-2_Interface ***
RSM(config-if)#no shut

7. Configure the necessary routing information:
RSM(config)#router ospf 100
RSM(config-router)#network 10.10.10.0 0.0.0.255 area 0
RSM(config-router)#network 10.10.20.0 0.0.0.255 area 0

8. Once this much is set, you should be able to ping the addresses:
RSM#ping 10.10.10.1
RSM#ping 10.10.20.1

9. Configure the Ethernet ports to the particular VLAN on specific ports.
For example, for the 18 port on the third module, the command will be as follows:
Console>(enable)set vlan 3/18 10

10. Connect machines to the specified ports. For machines in the example-1 network, the default gateway will be 10.10.10.1, and the port on the switch will be in VLAN number 10. For the example-2 network, the default-gateway for machines will be 10.10.20.1, and the port on the switch to which the machine will be connected will be VLAN number 20.

11. You should be able to ping and exchange information between the two subnets.

The Conversation

Follow the reactions below and share your own thoughts.