Warning: Invalid argument supplied for foreach() in /home/techrecipes/public_html/wp-content/themes/techrecipes/header.php on line 77

Cisco Hot Standby Router Protocol

Two routers are connected to the network and the two default gateways do not provide a completely reliable path in the event of an outage.
Although the ITA has some newer IP hosts that support dynamic router discovery with the ICMP Router Discovery Protocol (IRDP), it mostly has a large class of legacy host implementations that do not. These hosts are unable to find a new router when their default gateway becomes unavailable.The ITA is also concerned with IRDP’s administrative and processing overhead, security issues, and lack of support on the legacy platforms.Configuring HSRP on the two routers provides a fast fail-over mechanism that is transparent to the users. This allows hosts on the LAN segment to maintain access to the Web router if a single point of
failure occurs.


Note The routers require two Ethernet interfaces therefore Cisco 2621 routers or equivalent with dual Ethernet interfaces are required to complete this lab. However, this lab could be written to use the Cisco 2620, single Ethernet interface routers by substituting the Ethernet connection to the Web, with serial links and additional subnet (e.g., 10.1.3.0/24).

Web#show running-config
Building configuration...
Current configuration : 679 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Web
!
enable password class
!
memory-size iomem 10
ip subnet-zero
!
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
auto-summary
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

East#show running-config
Building configuration...
Current configuration : 882 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname East
!
enable password class
!
memory-size iomem 10
ip subnet-zero
!
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface FastEthernet0/1
ip address 10.1.2.3 255.255.255.0
duplex auto
speed auto
standby preempt
standby 1 ip 10.1.2.1
standby 1 preempt
standby 1 track FastEthernet0/0
standby 2 ip 10.1.2.254
standby 2 priority 95
standby 2 preempt
standby 2 track FastEthernet0/0
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
auto-summary
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

West#show running-config
Building configuration...
Current configuration : 882 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname West
!
enable password class
!
memory-size iomem 10
ip subnet-zero
!
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface FastEthernet0/1
ip address 10.1.2.2 255.255.255.0
duplex auto
speed auto
standby preempt
standby 1 ip 10.1.2.1
standby 1 priority 95
standby 1 preempt
standby 1 track FastEthernet0/0
standby 2 ip 10.1.2.254
standby 2 preempt
standby 2 track FastEthernet0/0
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
auto-summary
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

The Conversation

Follow the reactions below and share your own thoughts.